PhilCs H5 A3 build

Share your building progress here!
stephen_usher
Trusted Guru
Trusted Guru
Posts: 1247
Joined: Mon Nov 13, 2017 7:19 pm
Location: Oxford, UK.
Contact:

Re: PhilCs H5 A3 build

Post by stephen_usher » Fri Oct 30, 2020 9:10 pm

Obviously a blue meenie as he doesn't want to share his blueness.
Intro retro computers since before they were retro...
ZX81->Spectrum->Memotech MTX->Sinclair QL->520STM->BBC Micro->TT030->PCs & Sun Workstations.
Added code to the MiNT kernel (still there the last time I checked) + put together MiNTOS.
Collection now with added Macs, Amigas, Suns and Acorns.

User avatar
PhilC
Moderator
Moderator
Posts: 3865
Joined: Fri Mar 23, 2018 8:22 pm

Re: PhilCs H5 A3 build

Post by PhilC » Sat Oct 31, 2020 6:11 pm

Got my reset problem fixed and got some blue and even green now. Not sure where the black went :lol:
20201031_181032.jpg
20201031_181032.jpg (81.85 KiB) Viewed 984 times
If it ain't broke, test it to Destruction.

stephen_usher
Trusted Guru
Trusted Guru
Posts: 1247
Joined: Mon Nov 13, 2017 7:19 pm
Location: Oxford, UK.
Contact:

Re: PhilCs H5 A3 build

Post by stephen_usher » Sat Oct 31, 2020 6:22 pm

Trying to make people green with envy using a pull-up? ;-)
Intro retro computers since before they were retro...
ZX81->Spectrum->Memotech MTX->Sinclair QL->520STM->BBC Micro->TT030->PCs & Sun Workstations.
Added code to the MiNT kernel (still there the last time I checked) + put together MiNTOS.
Collection now with added Macs, Amigas, Suns and Acorns.

User avatar
PhilC
Moderator
Moderator
Posts: 3865
Joined: Fri Mar 23, 2018 8:22 pm

Re: PhilCs H5 A3 build

Post by PhilC » Sat Oct 31, 2020 6:26 pm

stephen_usher wrote:
Sat Oct 31, 2020 6:22 pm
Trying to make people green with envy using a pull-up? ;-)
Nah, I'm starting to think there is something wrong with the DAC, so I'll order another from exxos.

Mono mode works great though and everything else works great

Edit:

Definitely thinking something odd eith this DAC as every time I reboot there's a good chance the colors will change :lol: it was a lovely shade of cyan just now.
If it ain't broke, test it to Destruction.

stephen_usher
Trusted Guru
Trusted Guru
Posts: 1247
Joined: Mon Nov 13, 2017 7:19 pm
Location: Oxford, UK.
Contact:

Re: PhilCs H5 A3 build

Post by stephen_usher » Sat Oct 31, 2020 7:02 pm

:lol:
Intro retro computers since before they were retro...
ZX81->Spectrum->Memotech MTX->Sinclair QL->520STM->BBC Micro->TT030->PCs & Sun Workstations.
Added code to the MiNT kernel (still there the last time I checked) + put together MiNTOS.
Collection now with added Macs, Amigas, Suns and Acorns.

User avatar
PhilC
Moderator
Moderator
Posts: 3865
Joined: Fri Mar 23, 2018 8:22 pm

Re: PhilCs H5 A3 build

Post by PhilC » Thu Nov 05, 2020 5:18 pm

I've got the H5 on the bench today to try and work out what's broken with it as ive done all the fixes, am using good chips, etc.

This is what I get when we boot to a floppy in medium resolution.
20201105_171646.jpg
20201105_171646.jpg (100.13 KiB) Viewed 800 times
If it ain't broke, test it to Destruction.

stephen_usher
Trusted Guru
Trusted Guru
Posts: 1247
Joined: Mon Nov 13, 2017 7:19 pm
Location: Oxford, UK.
Contact:

Re: PhilCs H5 A3 build

Post by stephen_usher » Thu Nov 05, 2020 5:56 pm

Is the Shifter not changing res then?
Intro retro computers since before they were retro...
ZX81->Spectrum->Memotech MTX->Sinclair QL->520STM->BBC Micro->TT030->PCs & Sun Workstations.
Added code to the MiNT kernel (still there the last time I checked) + put together MiNTOS.
Collection now with added Macs, Amigas, Suns and Acorns.

User avatar
PhilC
Moderator
Moderator
Posts: 3865
Joined: Fri Mar 23, 2018 8:22 pm

Re: PhilCs H5 A3 build

Post by PhilC » Thu Nov 05, 2020 6:00 pm

stephen_usher wrote:
Thu Nov 05, 2020 5:56 pm
Is the Shifter not changing res then?
No, it stays in low res
If it ain't broke, test it to Destruction.

stephen_usher
Trusted Guru
Trusted Guru
Posts: 1247
Joined: Mon Nov 13, 2017 7:19 pm
Location: Oxford, UK.
Contact:

Re: PhilCs H5 A3 build

Post by stephen_usher » Thu Nov 05, 2020 6:07 pm

Does it look OK if started in low res?

I'm wondering if a data line isn't connected and hence the wrong data is going into a register. Either that it an address line and it's not writing the data into the right I/O port location.

I take it that you've 'scoped all the data and address lines.
Intro retro computers since before they were retro...
ZX81->Spectrum->Memotech MTX->Sinclair QL->520STM->BBC Micro->TT030->PCs & Sun Workstations.
Added code to the MiNT kernel (still there the last time I checked) + put together MiNTOS.
Collection now with added Macs, Amigas, Suns and Acorns.

User avatar
PhilC
Moderator
Moderator
Posts: 3865
Joined: Fri Mar 23, 2018 8:22 pm

Re: PhilCs H5 A3 build

Post by PhilC » Thu Nov 05, 2020 8:32 pm

And we're fixed.
20201105_203025.jpg
20201105_203025.jpg (90.96 KiB) Viewed 770 times
RW on the shifter has a fault on the pcb, I fitted a bodge wire from pin 9 on IO port 1 to pin 31 on the shifter and were all up and running, so no wonder things were confused.
If it ain't broke, test it to Destruction.

Post Reply

Return to “H5 A3 USER BUILDS”