STOCK MEGA4 16MHZ V1.5 BOOSTER INSTALL

Help & information about the V1.5 booster.
User avatar
exxos
Site Admin
Site Admin
Posts: 8630
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STOCK MEGA4 16MHZ V1.5 BOOSTER INSTALL

Post by exxos » Fri Nov 16, 2018 5:14 pm

PaulJ wrote:
Fri Nov 16, 2018 5:12 pm
Yup machine has "Joe Master" caps. Doesn't get any better than that.. Probably means this was a master computer at some point in its life!!
Might be friends with Jeff the resistor... :shrug:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 855
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: STOCK MEGA4 16MHZ V1.5 BOOSTER INSTALL

Post by PaulJ » Fri Nov 16, 2018 5:59 pm

Forgottenmyname wrote:
Fri Nov 16, 2018 5:14 pm
I've deleted that add-on too PaulJ, I've got a 2.2 booster in one of mine so far, buffer board still to do but seems ok.
Good to know, I'd rather have the 2.2 but performance wise the 1.5 is close, its just missing the ability to run TOS 2.06 but I'll get to that later, loading it into memory works for me in the interum. :) :) :)

Well there's 6 inches of snow out there so I'm going out and uncover some asphalt before it all turns to ice tonight.. :cussing: :cussing:

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 855
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: STOCK MEGA4 16MHZ V1.5 BOOSTER INSTALL

Post by PaulJ » Sat Nov 17, 2018 2:09 am

Snows done so time to get the old processor out with screwing up the board. Clipped all the pins after unsoldering the small daughter card.
UG_1005.jpg
UG_1005.jpg (224.93 KiB) Viewed 1196 times
Ok, guess I'm committed, old 68k has been chopped out leaving only its legs.
UG_1006.jpg
UG_1006.jpg (324.88 KiB) Viewed 1196 times
Pulled all the legs out one at a time, heated up and used a pair of tweezers to remove the pin. Started cleaning out the holes with solder wick.
UG_1007.jpg
UG_1007.jpg (342.18 KiB) Viewed 1196 times
Attempted cleaning on all the holes, a few where stubborn so I'll catch them when I turn the board over.
UG_1008.jpg
UG_1008.jpg (344.07 KiB) Viewed 1196 times
Cleaned the board with alcohol, an acid brush, and some alcohol wipes.
UG_1009.jpg
UG_1009.jpg (319.01 KiB) Viewed 1196 times

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 855
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: STOCK MEGA4 16MHZ V1.5 BOOSTER INSTALL

Post by PaulJ » Sat Nov 17, 2018 2:37 am

Back at it.. Here's what the bottom of the board looked like. Most of the holes were clean but there were a few that needed solder wicking from the bottom.
UG_1010.jpg
UG_1010.jpg (334.65 KiB) Viewed 1195 times
Remaining holes cleared and board cleaned same as top.
UG_1011.jpg
UG_1011.jpg (360.71 KiB) Viewed 1195 times
Socket soldered and ready for the booster.
UG_1013.jpg
UG_1013.jpg (311.72 KiB) Viewed 1195 times
FInishing touches, booster plugged in, 16 mhz clock un-fu*kit plugged in, and a wire run to the 16 mhz output on the un-fu*kit board. Couldn't find the specified solder jumper so I connected the CE lead on the booster to one of the CE pin on the fast ROM adapter. We're done.. if it works.. :excited: :excited: :excited: :excited: :excited:
UG_1015.jpg
UG_1015.jpg (391.73 KiB) Viewed 1195 times

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 855
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: STOCK MEGA4 16MHZ V1.5 BOOSTER INSTALL

Post by PaulJ » Sat Nov 17, 2018 3:10 am

Congrats !! it works on power up !!! :cheer: :cheer: :cheer: :cheer: :cheer: :cheer:

UG_1017.jpg
UG_1017.jpg (264.15 KiB) Viewed 1195 times

Bench6 has been running for a while.. no hiccups..
UG_1019.jpg
UG_1019.jpg (33.18 KiB) Viewed 1195 times

So that's good still have an issue with the power supply being a little wide. Will nibble a little of the supply tomorrow and we should be good.

The power supply is close but needs to get adjusted.
UG_1020.jpg
UG_1020.jpg (198.3 KiB) Viewed 1195 times

User avatar
exxos
Site Admin
Site Admin
Posts: 8630
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STOCK MEGA4 16MHZ V1.5 BOOSTER INSTALL

Post by exxos » Sat Nov 17, 2018 9:45 am

:bravo: :goodpost:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 855
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: STOCK MEGA4 16MHZ V1.5 BOOSTER INSTALL

Post by PaulJ » Sat Nov 17, 2018 11:33 pm

Day later and still running fine. Took care of the power supply interference.
UG_1021.jpg
UG_1021.jpg (288.46 KiB) Viewed 1164 times

User avatar
exxos
Site Admin
Site Admin
Posts: 8630
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STOCK MEGA4 16MHZ V1.5 BOOSTER INSTALL

Post by exxos » Sun Nov 18, 2018 11:05 am

Would it fit without the shifter being in a socket ? Also if the buffer board in a socket ? I half recall it probably would just fit under the OSU if it was all low enough.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 855
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: STOCK MEGA4 16MHZ V1.5 BOOSTER INSTALL

Post by PaulJ » Sun Nov 18, 2018 1:56 pm

exxos wrote:
Sun Nov 18, 2018 11:05 am
Would it fit without the shifter being in a socket ? Also if the buffer board in a socket ? I half recall it probably would just fit under the OSU if it was all low enough.
Yes, if the shifter and gal were soldered in the clock fix board it would fit under the power supply I believe. However I don't think you could shoulder the clock fix board in the main board because the OSC is to high. Maybe if you had a good thin insulator to put on top of the OSC. When you make the board you could move the shifter and gal toward the DMA chip a little and that would work. I see have a number of boards to that's most likely no an option.
IMG_2080.JPG
IMG_2080.JPG (2.07 MiB) Viewed 1145 times

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 855
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: STOCK MEGA4 16MHZ V1.5 BOOSTER INSTALL

Post by PaulJ » Sun Nov 18, 2018 2:13 pm

The sockets that the flash rom card plug into are ruined because of the rom adaptors with the huge pins were plugged into them. I would normally just solder the fast rom card in but I'm thinking about working on the diagrom code and I don't want to burn proms every iteration so I'm think of buying another OSTRICH so I can provide 16 bits of rom instead of 8. I used the pictured OSTRICH to debug some 6809 rom code. You plug it in the rom socket, download code and it emulated a rom. Its built to plug into a auto computer and debug its code but it worked great on the 6809 computer I have.
UG_1022.jpg
UG_1022.jpg (242.59 KiB) Viewed 1142 times

Post Reply

Return to “ST 16MHz V1.5 BOOSTER”