Floppy write protected (when its not) fix.

The latest tweaks and fixes to keep your machine running in tip-top shape.
Post Reply
User avatar
exxos
Site Admin
Site Admin
Posts: 11843
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Floppy write protected (when its not) fix.

Post by exxos » Thu Dec 06, 2018 6:10 pm

IMG_3667.JPG
IMG_3667.JPG (61.72 KiB) Viewed 3138 times

This is a shortened version of this thread..viewtopic.php?f=23&t=1410

The issue was with a STE machine, which was continuously or intermittently reporting the floppy was write protected when it was not.

The assumptions are the drive has been tested and working fine in another machine. It is also assumed that the WP pin on the 1772 is always high (for write enabled operations).

The fix for this issue to solder a 10K bussed resistor array to the 1772 databus pins as illustrated below.

The white wire connects the common pin on the resistor array to 5V.
ste_fix.jpg
ste_fix.jpg (68.33 KiB) Viewed 3138 times
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

terriblefire
Moderator Team
Moderator Team
Posts: 3195
Joined: Mon Aug 28, 2017 10:56 pm
Location: Glasgow, UK
Contact:

Re: Floppy write protected (when its not) fix.

Post by terriblefire » Mon Dec 31, 2018 5:56 pm

Just made this mod to my STFM

Hasn’t helped my issue but was easy to do




C8242480-1053-4E8D-8CB4-9FB.jpg
C8242480-1053-4E8D-8CB4-9FB.jpg (58.07 KiB) Viewed 3138 times
BAC020C4-60EB-4C31-9A95-5C7.jpg
BAC020C4-60EB-4C31-9A95-5C7.jpg (114.94 KiB) Viewed 3138 times
———
I get cranky when asked to repeat myself.

User avatar
PhilC
Moderator
Moderator
Posts: 3469
Joined: Fri Mar 23, 2018 8:22 pm

Re: Floppy write protected (when its not) fix.

Post by PhilC » Sun Jan 20, 2019 1:09 pm

Just checking, as I dont have any 10k, do you think it will work with 4.7k?
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 11843
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Floppy write protected (when its not) fix.

Post by exxos » Sun Jan 20, 2019 1:16 pm

Forgottenmyname wrote:
Sun Jan 20, 2019 1:09 pm
Just checking, as I dont have any 10k, do you think it will work with 4.7k?
Assume would be ok..
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
DoG
Posts: 384
Joined: Sat Apr 07, 2018 12:26 pm

Re: Floppy write protected (when its not) fix.

Post by DoG » Sat Apr 06, 2019 2:28 pm

Did this on a STfm (070789-001 RevD) since I fitted 2.2 booster on it and having problem reading disks. Works perfectly now.

EDIT: v2.3 booster

User avatar
exxos
Site Admin
Site Admin
Posts: 11843
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Floppy write protected (when its not) fix.

Post by exxos » Sat Apr 06, 2019 2:30 pm

DoG wrote:
Sat Apr 06, 2019 2:28 pm
Did this on a STfm (070789-001 RevD) since I fitted 2.2 booster on it and having problem reading disks. Works perfectly now.
Thanks for letting us know :thumbup:
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

tzok
Posts: 216
Joined: Sat Dec 30, 2017 2:27 pm

Re: Floppy write protected (when its not) fix.

Post by tzok » Fri Jul 31, 2020 10:10 am

This fix solved my issue with ACSI CF adapter in 1040 STfm. Before, it was writing complete garbage on the CF card, after applying this fix - works like a charm!

P.S.
Thanks to tOri from atari.org.pl, I probably have a fully working ACSI to CF adapter for ST. And it is fast - 1.8 MB/s on stock ST.

Post Reply

Return to “TWEAKS & FIXES”