exxos blog - random goings on

Blogs & guides and tales of woo by forum members.
User avatar
exxos
Site Admin
Site Admin
Posts: 10918
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: exxos blog - random goings on

Post by exxos » Mon Jun 10, 2019 11:53 am

I mashed up a "phase corrector" board...

Capture.JPG
Capture.JPG (55.8 KiB) Viewed 726 times

so my plan is...

MMU 16MHz output > 7404 inverter > 5ns stepped delay line > 161...

..where the 161 generates the 8Mhz and 4MHz and 2MHz clocks... Which will be in phase with the MMU clock.

Delay wise, based on the 8MHz clock can vary up to 125ns. Which is basically what my scope was showing. So inverting it halfs that to about 62ns... the 7404 (SN74LVC1G04 ) will add about 2ns delay, so basically nothing.. the 161 will add about 5ns.... so 62ns - 7ns = 55ns stepped delay.. 5ns steps should be enough.

So basically what is happening is, we are taking the clock and delaying it until its back in phase to what its supposed to be. Because of propagation delays we can only add more delays until its back in proper phase again. So while a full clock may be 125ns, we run something like 100ns delay + propagation delays to bring it back to 125ns. This way I can take delays off in 5ns steps to adjust and compensate for propagation delays.
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 10918
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: exxos blog - random goings on

Post by exxos » Mon Jun 10, 2019 3:58 pm

V3 PSU bracket just finished printing :)

IMG_4311.JPG
IMG_4311.JPG (276.93 KiB) Viewed 711 times

The switch bolts are out of the way. I may need to move that section backwards a tiny bit in fact. Though my case is broken and hard to align stuff up exactly to check.


IMG_4312.JPG
IMG_4312.JPG (199.19 KiB) Viewed 709 times

The case posts seem to wide to fit inside the holes :roll: But at least its a step in the right direction I think.

IMG_4313.JPG
IMG_4313.JPG (250.12 KiB) Viewed 709 times
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 10918
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: exxos blog - random goings on

Post by exxos » Mon Jun 10, 2019 4:50 pm

Icky kindly supplied me some full sized prints.. So now I can check dimensions etc better now...

IMG_4315.JPG
IMG_4315.JPG (265.11 KiB) Viewed 706 times

IMG_4316.JPG
IMG_4316.JPG (360.67 KiB) Viewed 706 times

EDIT:

So the first issue spotted is the floppy holes are "out".. Problem there seems to be the MB is 3mm to short on the right, so its pushed the floppy holes 3mm to the left.. so thats the first mistake to correct...

IMG_4317.JPG
IMG_4317.JPG (192.77 KiB) Viewed 704 times
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 10918
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: exxos blog - random goings on

Post by exxos » Mon Jun 10, 2019 6:01 pm

So far, the top left midi port had to be moved down fractionally. The port under it had to be moved up fractionally.. The left side of the cartridge port area had to be moved up slightly. monitor connector had to be moved fractionally to the left, all other ports had to be moved fractionally to the right.

The width of the board was actually 3 mm too short, and this threw out the floppy holes and a serial connector. so I moved all that across 3mm. I have also added the mouse area cutout on the board.

1.jpg
1.jpg (185.79 KiB) Viewed 695 times
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 10918
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: exxos blog - random goings on

Post by exxos » Mon Jun 10, 2019 10:09 pm

Slow progress.. but the DB19 holes were wrong.. so fixed those... also started adding in the bottom (front of MB) holes...

Also been thinking I may add a 5th 68K socket next to the right side of the board (so it misses the center hole) I mean the falcon RAM board fits about there.. so there be height for something small anyway.

1.jpg
1.jpg (142.09 KiB) Viewed 680 times
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PhilC
Moderator
Moderator
Posts: 3117
Joined: Fri Mar 23, 2018 8:22 pm

Re: exxos blog - random goings on

Post by PhilC » Mon Jun 10, 2019 10:21 pm

You've got room for at least 1 more turned 90 degrees under the 6850s?
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 10918
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: exxos blog - random goings on

Post by exxos » Mon Jun 10, 2019 10:23 pm

PhilC wrote:
Mon Jun 10, 2019 10:21 pm
You've got room for at least 1 more turned 90 degrees under the 6850s?
it be under the floppy drive so maybe not a good place, but it can fit where the filly style boards have the CPU (where the STFM ACIA's are)... Could have 6 sockets...

Not sure about the full size board yet.. but gotta fill it up with something I guess :P
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PhilC
Moderator
Moderator
Posts: 3117
Joined: Fri Mar 23, 2018 8:22 pm

Re: exxos blog - random goings on

Post by PhilC » Mon Jun 10, 2019 10:34 pm

Smaller board, less pennies
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 10918
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: exxos blog - random goings on

Post by exxos » Tue Jun 11, 2019 12:02 am

M'kay...

0.jpg
0.jpg (28.23 KiB) Viewed 657 times
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PhilC
Moderator
Moderator
Posts: 3117
Joined: Fri Mar 23, 2018 8:22 pm

Re: exxos blog - random goings on

Post by PhilC » Tue Jun 11, 2019 6:41 am

Did you press the Any Key again?
If it ain't broke, test it to Destruction.

Post Reply

Return to “MEMBER BLOGS”