V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Help & information about the V2.X series boosters.
User avatar
exxos
Site Admin
Site Admin
Posts: 7141
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Fri Jun 14, 2019 5:41 pm

So after more testing, now the blitter seem sulky :roll: It just locks up halfway through doing the test it doesn't bomb or anything... And yet I have never had any issues with the blitter with these boards that I recall anyway.. Possible it could be a iffy socket.. But these are problems are extremely difficult to track down :roll:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7141
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Fri Jun 14, 2019 6:16 pm

:WTF:

This happens when just the normal 68000 in place (stock system) tried 3 known working blitters.. resoldered the CPU & blitter socket :shrug:

IMG_4334.JPG
IMG_4334.JPG (42.13 KiB) Viewed 214 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PhilC
Moderator
Moderator
Posts: 1539
Joined: Fri Mar 23, 2018 8:22 pm

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by PhilC » Fri Jun 14, 2019 6:46 pm

does it still work at 8mhz? You're certainly not having much luck tonight.
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 7141
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Fri Jun 14, 2019 6:53 pm

PhilC wrote:
Fri Jun 14, 2019 6:46 pm
does it still work at 8mhz? You're certainly not having much luck tonight.
It's now a stock machine... so the boards died somehow.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PhilC
Moderator
Moderator
Posts: 1539
Joined: Fri Mar 23, 2018 8:22 pm

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by PhilC » Fri Jun 14, 2019 6:56 pm

exxos wrote:
Fri Jun 14, 2019 6:53 pm
PhilC wrote:
Fri Jun 14, 2019 6:46 pm
does it still work at 8mhz? You're certainly not having much luck tonight.
It's now a stock machine... so the boards died somehow.
Certainly feel your pain today! PSU maybe?
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 7141
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Fri Jun 14, 2019 7:00 pm

PhilC wrote:
Fri Jun 14, 2019 6:56 pm
Certainly feel your pain today! PSU maybe?
its my new red one :)

Oddly I just found out the half of the databus is pulled up next to the MFP, So thats been a long running thing nobody has ever noticed.. I changed the address and databus ones, or so I thought, to 2.2K, but D0-4 is on a pull up no where near the CPU, madness.. so will change that one now.. maybe get lucky.

EDIT:

Nope. Guess I will have to change the blitter socket :(
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7141
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Fri Jun 14, 2019 7:37 pm

Socket changed, still the same :( Never known a stock board be grumpy like this either :roll: I only just kitted this board out like a week ago because my previous one died for no reason.. now looking on starting on a 3rd board.. geeze...
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7141
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Fri Jun 14, 2019 8:30 pm

Tried a totally different machine, and still getting the same error... I think there is some issue with the diagnostic cartridge test itself :roll:

So blitter is now working on this other board (tested wit GB6) , but the one I actually trying to test the booster on this basically resets not long after I turn the machine on, so that does have some odd fault which obviously is not actually related to the blitter :roll: But saying that, when the blitter is removed, the machine does work :pullhair: :pullhair: :stars: :stars:

EDIT:

and now the blitter is working in the machine it wasn't doing earlier , WTF is going on :shock:

Plugged the SEC back in and blitter acting up again :roll:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PhilC
Moderator
Moderator
Posts: 1539
Joined: Fri Mar 23, 2018 8:22 pm

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by PhilC » Fri Jun 14, 2019 8:40 pm

:dizzy:
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 7141
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Fri Jun 14, 2019 8:48 pm

Plugged the original SEC back in, same blitter issues... turned on and off server times, now its working fine again..

There has to be something screwy with the MMU wakeup states or something, because the fault changes from just powering off and on again it seems.. I can press the reset button loads and it doesn't make it better or worse, its only a power up issue... I'm really starting to hate the Atari MMU these days :evil: :evil:

EDIT:

Several turn off-on's and 2 bombs after the Fuji now.. oddly that was what TF's board was doing as well.. Power off a few more times, working fine again.

I'm also wondering if these are the issues I had with the PAK boards as it didn't work on my machines, but worked on RJ's.. I bet if I powered off and on enough times that would boot up as well..
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply