TF534 + Mem68k

TF534 - 68030 + More RAM Board (More compatible with amiga hardware)

Moderators: terriblefire, Terriblefire Moderator

ProfPlum
Posts: 10
Joined: Mon Sep 16, 2019 3:02 am

Re: TF534 + Mem68k

Post by ProfPlum » Sat Sep 21, 2019 1:40 am

May I ask did you build the Mem68k yourself or did you purchase it from someone.
I'm willing to try the Mem68k with my TF534/A2000

User avatar
arkadiusz.makarenko
Trusted Guru
Trusted Guru
Posts: 713
Joined: Wed Jun 19, 2019 7:36 am
Location: Edinburgh

Re: TF534 + Mem68k

Post by arkadiusz.makarenko » Sat Sep 21, 2019 9:05 pm

I found this: https://rover.ebay.com/rover/0/0/0?mpre ... 3018029740

I think I will build one soon.
Do not trust people. They are capable of greatness.
~ Stanislaw Lem

robban
Posts: 13
Joined: Tue Feb 12, 2019 9:15 am
Location: Finland

Re: TF534 + Mem68k

Post by robban » Mon Sep 23, 2019 9:16 am

I ordered 4 empty PCBs from that exact eBay-listing, desoldered memory chips some old sticks of DRAM and then assembled them myself. I still have 3 of them extra, but since the first one I tried testing worked first time I did not test them further.
If you like I can test to make sure that the rest of the MEM68Ks work and you can have them for some reasonable price?

User avatar
arkadiusz.makarenko
Trusted Guru
Trusted Guru
Posts: 713
Joined: Wed Jun 19, 2019 7:36 am
Location: Edinburgh

Re: TF534 + Mem68k

Post by arkadiusz.makarenko » Mon Sep 23, 2019 11:28 am

I couldn't find brand new ram chips from reputable sources? I guess they are obsolete? But the same guy who seek PCB sell "parts", without cpld.
Do not trust people. They are capable of greatness.
~ Stanislaw Lem

robban
Posts: 13
Joined: Tue Feb 12, 2019 9:15 am
Location: Finland

Re: TF534 + Mem68k

Post by robban » Mon Sep 23, 2019 11:41 am

I believe they are obsolete unfortunately. I looked around for a while as well, then settled for used memory from random eBayer. The ones i found are KM416C4104AS wich were said to be "maybe compatible" for this. So far they seem to work perfectly.

User avatar
arkadiusz.makarenko
Trusted Guru
Trusted Guru
Posts: 713
Joined: Wed Jun 19, 2019 7:36 am
Location: Edinburgh

Re: TF534 + Mem68k

Post by arkadiusz.makarenko » Mon Sep 23, 2019 4:33 pm

robban wrote:
Mon Sep 23, 2019 11:41 am
I believe they are obsolete unfortunately. I looked around for a while as well, then settled for used memory from random eBayer. The ones i found are KM416C4104AS wich were said to be "maybe compatible" for this. So far they seem to work perfectly.
Did you have to modify Amiga 500 itself? I don't get that information about autoconfig and installing resistors?
Do not trust people. They are capable of greatness.
~ Stanislaw Lem

robban
Posts: 13
Joined: Tue Feb 12, 2019 9:15 am
Location: Finland

Re: TF534 + Mem68k

Post by robban » Tue Sep 24, 2019 9:30 am

No, it just seemed to work by bridging the "autoconfig-in" jumper to ground. To be honest I do not know in which order the Mem68K and TF534 configures their memory, but it did work. The 534 4mb ended up in Zorro3-space and the Mem68K filled Zorro2 with its 8mb.

The one thing I had problem with though were the round female socket-header pins (https://www.ebay.com/itm/5Pcs-40Pin-2-5 ... SwHnFVs8UK). Since this board is supposed to be inserted into the 68k-socket and then having a 68000 (or in this case the TF534) on top of it, I tried those kind of pins first. They provided very poor connection and only worked for seconds at a time when i pushed down on the assembly. That was why I tried the method in this thread instead.

terriblefire
Moderator Team
Moderator Team
Posts: 3472
Joined: Mon Aug 28, 2017 10:56 pm
Location: Glasgow, UK
Contact:

Re: TF534 + Mem68k

Post by terriblefire » Tue Sep 24, 2019 10:20 am

robban wrote:
Tue Sep 24, 2019 9:30 am
No, it just seemed to work by bridging the "autoconfig-in" jumper to ground. To be honest I do not know in which order the Mem68K and TF534 configures their memory, but it did work. The 534 4mb ended up in Zorro3-space and the Mem68K filled Zorro2 with its 8mb.
The onboard TF ram is always configured first.
———
I get cranky when asked to repeat myself.

robban
Posts: 13
Joined: Tue Feb 12, 2019 9:15 am
Location: Finland

Re: TF534 + Mem68k

Post by robban » Tue Sep 24, 2019 10:43 am

terriblefire wrote:
Tue Sep 24, 2019 10:20 am
The onboard TF ram is always configured first.
Ok! I've read somewhere that it is sometimes necessary to daisy-chain autoconfig-out to the autoconfig-in of any following device. Is this only relevant if there are several devices on the bus and you wish to set the order of their configuration?

terriblefire
Moderator Team
Moderator Team
Posts: 3472
Joined: Mon Aug 28, 2017 10:56 pm
Location: Glasgow, UK
Contact:

Re: TF534 + Mem68k

Post by terriblefire » Tue Sep 24, 2019 11:09 am

robban wrote:
Tue Sep 24, 2019 10:43 am
terriblefire wrote:
Tue Sep 24, 2019 10:20 am
The onboard TF ram is always configured first.
Ok! I've read somewhere that it is sometimes necessary to daisy-chain autoconfig-out to the autoconfig-in of any following device. Is this only relevant if there are several devices on the bus and you wish to set the order of their configuration?
I've explained this many times.. The Amiga doesnt see the autoconfig requests until the TF card is configured. So nothing like that is needed. possibly You might have an issue with the mem68k board and trapdoor expansions at the same time... but the TF doesnt get involved in that.
———
I get cranky when asked to repeat myself.

Post Reply

Return to “TF534 (OBSOLETE)”