EMUTOS & ULTRASATAN & SEC BOOSTER CRASHES

News,announcements,programming,fixes,game patches & discussions.

Moderator: troed

BlankVector
Posts: 65
Joined: Fri Sep 15, 2017 10:51 pm

Re: EMUTOS & ULTRASATAN & SEC BOOSTER CRASHES

Post by BlankVector » Tue Jan 21, 2020 8:31 pm

This is once again the proof that EmuTOS rulez for debugging hardware :mrgreen:
Thanks to everyone involved.
Subscribe to my Vretrocomputing channel on YouTube and Facebook. Latest video: Replace Atari STE ROMs with EEPROMs.

User avatar
exxos
Site Admin
Site Admin
Posts: 12239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: EMUTOS & ULTRASATAN & SEC BOOSTER CRASHES

Post by exxos » Tue Jan 21, 2020 8:36 pm

BlankVector wrote:
Tue Jan 21, 2020 8:31 pm
This is once again the proof that EmuTOS rulez for debugging hardware :mrgreen:
:bravo:


So does anyone know whats going on at address FA2E26 in the diagnostic cart ? I keep cranking the speeds of my booster hence keep running into new errors ;)


EDIT:
EMUTOS and TOS206 doesn't even try to start, but TOS104 mostly tries, or row of bombs.

EDIT2:
On power up TOS104 accesses the floppy (I hear it spin up) then I get 3 bombs... if I reset I get a row of bombs. Happens each time.
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

czietz
Posts: 320
Joined: Sun Jan 14, 2018 1:02 pm

Re: EMUTOS & ULTRASATAN & SEC BOOSTER CRASHES

Post by czietz » Tue Jan 21, 2020 9:02 pm

exxos wrote:
Tue Jan 21, 2020 8:36 pm
So does anyone know whats going on at address FA2E26 in the diagnostic cart ?
Nothing spectacular or crash-worthy: Just preparing a video counter access that will happen a bit later. (EDIT: Phrased wrong before: even though it's the video counter, the registers are not in the Shifter but in the MMU.)
fa2e26.png
fa2e26.png (99.5 KiB) Viewed 935 times

User avatar
exxos
Site Admin
Site Admin
Posts: 12239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: EMUTOS & ULTRASATAN & SEC BOOSTER CRASHES

Post by exxos » Tue Jan 21, 2020 9:08 pm

Thanks.. I think that time it was a iffy connection on my board :roll:

Still the same problem though that TOS104 tries to boot, but get 3 bombs. just no way to really know what is tripping up now.
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply

Return to “SOFTWARE PROGRAMMING & DISCUSSION”