Video problems Terriblefire 330LC

General hardware issues and troubleshooting etc

Moderators: terriblefire, Terriblefire Moderator

Post Reply
AmigaCD64
Posts: 1
Joined: Sat Aug 01, 2020 12:20 am

Video problems Terriblefire 330LC

Post by AmigaCD64 » Sat Aug 01, 2020 12:26 am

Hi, i have a amiga CD32, when trying to run games with 3D objects and certain other games the graphics is wrong/scrambeled. Doom 1 and 2 dont work, gloom deluxe wont work. Several demos wont run right. This problem is only present when using the terriblefire 330 LC, when unplugging it all is okay. Got any ideas? This is what gloom deluxe looks like: Regular Gloom workes fine.
Attachments
IMG_4148.JPG
IMG_4148.JPG (226.94 KiB) Viewed 208 times

alenppc
Moderator Team
Moderator Team
Posts: 578
Joined: Thu Nov 08, 2018 12:59 pm

Re: Video problems Terriblefire 330LC

Post by alenppc » Sat Aug 01, 2020 12:35 am

This is one of mine so I can help you look into it. Can you give me some info?

What c2p routines are you using? Doom runs fine over here.

I sent you a list of questions about your configuration over PM so we don’t spam the thread needlessly.

alenppc
Moderator Team
Moderator Team
Posts: 578
Joined: Thu Nov 08, 2018 12:59 pm

Re: Video problems Terriblefire 330LC

Post by alenppc » Sat Aug 01, 2020 1:29 am

Update: the 020 games that run from CD often cause issues like this on a 030 with fast ram. These games need to be run from the CF card...

Thanks

matt020
Posts: 152
Joined: Sun Sep 29, 2019 9:17 am
Location: West Australia

Re: Video problems Terriblefire 330LC

Post by matt020 » Sat Aug 01, 2020 1:57 am

I once had similar issues but it would take a small amount of time to occur, and I concluded it was heat related. If this has been resolved, I'll stay out of it...

alenppc
Moderator Team
Moderator Team
Posts: 578
Joined: Thu Nov 08, 2018 12:59 pm

Re: Video problems Terriblefire 330LC

Post by alenppc » Sat Aug 01, 2020 2:02 am

Actually most of these CD32 CD compilations were made with basic 020 in mind so they don’t patch the Akiko or don’t work with fast ram.

Furthermore the rev0 Akiko c2p won’t work at all on 030.

Post Reply

Return to “AMIGA HARDWARE HELP”