STE V1.5 32MHz BOOSTER - STATUS

Help & information about the STE V1 booster.
User avatar
exxos
Site Admin
Site Admin
Posts: 9604
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Fri Jul 20, 2018 7:33 pm

Now I have a cap in series with the 40MHz OSC... DC offset gone.. made no difference :roll:
40_cap.png
40_cap.png (4.14 KiB) Viewed 1179 times

So will try increasing the DC offset as that is what is hinted in my previous scope images.. even though GAL spec wise it shouldn't work at all...


Current mash up...

IMG_3072.JPG
IMG_3072.JPG (143.25 KiB) Viewed 1175 times
40_os.png
40_os.png (4.4 KiB) Viewed 1175 times

So far it locked up on the last GB6 test.. but will keeping doing more testing...

Second pass it crashed on first test... I adjusted the DC offset to match the 3.3V one.. still crashed on first test :roll: :shrug: :shrug:

EDIT:
So spraying the whole board with freezer spray seems to make it more stable... its passed all loops 4 times after spraying the thing... and yet even 25MHz which is half the speed still refuses to work, so its not like its overheating from the raw MHz on the GAL or CPU.

Will add a few pF onto the OSC output.. see if that helps.. Actually had to do that on the GAL output...
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
dhedberg
Posts: 95
Joined: Tue Sep 12, 2017 8:21 pm
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by dhedberg » Fri Jul 20, 2018 8:16 pm

The magic world of electronics! ;)
Daniel, New Beat - http://newbeat.atari.org. Like demos? Have a look at our new Falcon030 demo and feel the JOY.

User avatar
exxos
Site Admin
Site Admin
Posts: 9604
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Fri Jul 20, 2018 8:17 pm

dhedberg wrote:
Fri Jul 20, 2018 8:16 pm
The magic world of electronics! ;)
Indeed! I need a easier hobby! Then people wonder why I don't wake up one morning and slap on fast-ram, fast-tos, flash rom, ide all at once..
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 9604
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Sat Jul 21, 2018 9:09 am

Left it running over night.... So over 8 hours run time so far...

166.jpg
166.jpg (51.1 KiB) Viewed 1138 times

Will see how it goes on throughout the day as "room temp" will get hotter..

I have changed some resistors on the board.. oddly in x10 mode on my probes the 40MHz goes to 6V, on x1 mode, it goes to 4V.. So I think the scope is loading the signal a lot more than I had thought and giving me incorrect voltage readings. So I've "calibrated" the board this time on x10..
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 9604
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Sat Jul 21, 2018 6:36 pm

Small update..

Got to loop 250ish, so runtime was approx 13 hours. I think the ambient temperature was the tipping point.. The machine has been restarted.. So see how it goes.. but clearly my last fix has worked wonders as it ran for a long time this time...
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 9604
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Sun Jul 22, 2018 10:14 pm

Only just got home, but left it running for about 15mins then heated it all up with my gas soldering iron.. it crashed to desktop pretty quick..

So I added in another 33R onto the CPU clock.. didn't boot, so added 33R more onto the OSC clock output (to GAL input) and heated the board to around 110C! The thing is literally smoking and its still running so far.. Will have to leave it on for endless hours again and see what happens..
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
IngoQ
Site Admin
Site Admin
Posts: 945
Joined: Tue Aug 22, 2017 8:38 am
Location: Germany

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by IngoQ » Mon Jul 23, 2018 10:44 am

On a probably related note:

In the last couple of weeks I had a lot more crashes with my V1.5 boosted STE than usual. Mostly RAM related. And it was and still is quite hot here... Maybe a general issue?
Ingo :geek:

| Atari 1040STE@32MHz | Amiga 1200 (ACA1220) | Atari 800XL (U1MB, SIDE2) | Atari 130XL (Sophia DVI) | C64 (1541 Ultimate II, Rev3 RFMod Replacement) | TI 99/4A (F18A, 32k, FlashROM 99) | Sinclair ZX Spectrum 128 (Stereo, DivMMC) | Amstrad CPC664 (512k, M4 Wifi) | ... |

User avatar
exxos
Site Admin
Site Admin
Posts: 9604
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Mon Jul 23, 2018 11:20 am

IngoQ wrote:
Mon Jul 23, 2018 10:44 am
In the last couple of weeks I had a lot more crashes with my V1.5 boosted STE than usual. Mostly RAM related. And it was and still is quite hot here... Maybe a general issue?
I had Jonnie test his booster , I forgot how long, but going several hours.. Not saying there isn't a issue, its never been this hot here before so ambient temp is a lot hotter than normal.

Do you have laser temperature gun to measure CPU temp ?

I can suggest some things to try, I mostly have a general idea what's going on with it all now... might be worth stating a new topic as others could run into same issues..

EDIT:

Oh V1.5 booster you had not the proper STE booster, forgot sorry! Could be trickier to diagnose as other than your machine and my test machine, nobody else fitted it to a STE AFAIK.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2010
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by rubber_jonnie » Mon Jul 23, 2018 11:56 am

exxos wrote:
Mon Jul 23, 2018 11:20 am

I had Jonnie test his booster , I forgot how long, but going several hours.. Not saying there isn't a issue, its never been this hot here before so ambient temp is a lot hotter than normal.
Mine ran for nearly 24 hours and hit loop 427 if I recall correctly. It didn't stop, I stopped it.

Outside temp was 25-26 Degrees C on the day, and the room the machine was in has very poor ventilation (It's in the roof of my house), so although I had no way of testing, I'm confident it was at least 30 Degrees C in my room. The machine had its case on, but no upper metal shield.

When I lifted the lid at one point,the CPU was warm, but cool enough to touch. Not even the PSU was particularly hot.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
exxos
Site Admin
Site Admin
Posts: 9604
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Mon Jul 23, 2018 12:39 pm

rubber_jonnie wrote:
Mon Jul 23, 2018 11:56 am
Mine ran for nearly 24 hours and hit loop 427 if I recall correctly. It didn't stop, I stopped it.
:thumbup:

I realised after posting Ingo has V1.5 (STFM booster) fitted in his STE.. It was never intended for use on STE, but is basically same circuit as STE booster. Though of course never had much testing on the STE as wasn't a official upgrade for it.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply

Return to “STE V1 32MHz BOOSTER”