STE V1.5 32MHz BOOSTER - STATUS

Help & information about the STE V1 series boosters.
Locked
User avatar
exxos
Site Admin
Site Admin
Posts: 15299
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: exxosuk
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Mon Jul 23, 2018 3:58 pm

Having to put a fan on in the room now as its simply to hot in here now! CPU has run at like 30c for about 4 hours..

So think its safe to say its stable... :hide: .

Current run time is about 17 hours. I am still updating the previous post with results, though temps likely be dropping now anyway..
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 4138
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by rubber_jonnie » Mon Jul 23, 2018 4:13 pm

Those temps are really consistent, which has got to be a good thing.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
exxos
Site Admin
Site Admin
Posts: 15299
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: exxosuk
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Mon Jul 23, 2018 4:22 pm

rubber_jonnie wrote:
Mon Jul 23, 2018 4:13 pm
Those temps are really consistent, which has got to be a good thing.
Yeah, I mean its hottest day ever and CPU has peaked at 40c and still going. Though I heated the CPU to 110c yesterday.. though of course "losses" to the silicon die, even so, the die will have to have raised a fair bit temp wise, maybe 50c... Might try 48Mhz just for the hell of it..
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~

User avatar
PhilC
Moderator
Moderator
Posts: 4223
Joined: Fri Mar 23, 2018 8:22 pm

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by PhilC » Mon Jul 23, 2018 6:05 pm

Sounding promising to me , well done.

48mhz, none of this quitting whilst ahead malarky here!

Being an STE newb, is there room for a heatsink on top of the CPU when in situ? and maybe a quiet case fan for some extreme OC action, LOL.
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 15299
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: exxosuk
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Mon Jul 23, 2018 6:11 pm

Forgottenmyname wrote:
Mon Jul 23, 2018 6:05 pm
Sounding promising to me , well done.
:thumbup:
Forgottenmyname wrote:
Mon Jul 23, 2018 6:05 pm
48mhz, none of this quitting whilst ahead malarky here!
:lol: Well it doesn't work, not suprised really. I guess if I spent another 6 months on it it might be possible, but not worth it.
Forgottenmyname wrote:
Mon Jul 23, 2018 6:05 pm
Being an STE newb, is there room for a heatsink on top of the CPU when in situ? and maybe a quiet case fan for some extreme OC action, LOL.
I don't think it fits under the shielding even. So might have to be a chunk cut out of it. Not got around to looking into it yet.
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~

User avatar
exxos
Site Admin
Site Admin
Posts: 15299
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: exxosuk
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Tue Jul 24, 2018 8:01 pm

New super sexy PCBs arrived today :) pictures do not do them justice.
Now to find some time to actually build one up...

ste_red.jpg
ste_red.jpg (93.18 KiB) Viewed 1984 times
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~

User avatar
PhilC
Moderator
Moderator
Posts: 4223
Joined: Fri Mar 23, 2018 8:22 pm

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by PhilC » Tue Jul 24, 2018 8:48 pm

Those do look better than the green ones.

I do like the colour of the OSH Park purple though :-)
If it ain't broke, test it to Destruction.

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 4138
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by rubber_jonnie » Tue Jul 24, 2018 10:54 pm

Oooh nice :)
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
exxos
Site Admin
Site Admin
Posts: 15299
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: exxosuk
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Thu Jul 26, 2018 3:10 pm

Built-up 6 boards almost... 2 of them the CPUs went wonky :roll: I pasted the CPU pads, melted the solder, then pasted again like it did before, the problem is that it is very difficult to get the CPU to stay straight on the pads.. The next few I build I will just use one layer of paste..

So far this board is working.. I have not added on the resistor SIPs yet, I am waiting for them to arrive..

I will likely build up two or three as pre-release versions at a discount next week for forum members who are willing to try it out :)

IMG_3092.JPG
IMG_3092.JPG (132.57 KiB) Viewed 1900 times
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~

User avatar
PhilC
Moderator
Moderator
Posts: 4223
Joined: Fri Mar 23, 2018 8:22 pm

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by PhilC » Thu Jul 26, 2018 3:44 pm

Looking good to me again. Count me in for the test program if you'd like.
If it ain't broke, test it to Destruction.

Locked

Return to “STE V1 SERIES 32MHz BOOSTER”