STE V1.5 32MHz BOOSTER - STATUS

Help & information about the STE V1 series boosters.
Locked
User avatar
rubber_jonnie
Moderator
Moderator
Posts: 3949
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by rubber_jonnie » Thu Aug 02, 2018 9:53 am

exxos wrote:
Thu Aug 02, 2018 8:51 am
If you run the new booster do all tests, then load the STE20632 file, then you should see the speed difference between 32MHz and 40MHz.
Will do so as soon as I can.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
exxos
Site Admin
Site Admin
Posts: 15022
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: exxosuk
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Thu Aug 02, 2018 7:36 pm

Seems HD10.01 doesn't like booting in 40MHz mode for some odd reason :shrug:
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?

User avatar
PhilC
Moderator
Moderator
Posts: 4144
Joined: Fri Mar 23, 2018 8:22 pm

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by PhilC » Fri Aug 03, 2018 10:37 pm

Ok, so one 3.3v oscillator replaced with a 5v one and back in business, thanks Chris.

To celebrate, here are a couple of benchmarks.

Below is the 40mhz vs 8mhz STE
20180803_222939_resized.jpg
20180803_222939_resized.jpg (443.56 KiB) Viewed 2111 times
And below this is 40mhz vs 32mhz
20180803_222608_resized.jpg
20180803_222608_resized.jpg (445.31 KiB) Viewed 2111 times
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 15022
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: exxosuk
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Fri Aug 03, 2018 10:44 pm

Forgottenmyname wrote:
Fri Aug 03, 2018 10:37 pm
And below this is 40mhz vs 32mhz
hmmm, something not right with that... 32MHz has 309% ROM access, 368% 40MHz - 309% = 59% (yours whos 19% increase).

Similar with first test, 181% 32MHz, 203% 40MHz - 181% = 22% (your shows 12% increase)...
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?

User avatar
PhilC
Moderator
Moderator
Posts: 4144
Joined: Fri Mar 23, 2018 8:22 pm

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by PhilC » Fri Aug 03, 2018 10:49 pm

Could it be the different GB that I was using? If you look at the percentages for the 40mhz, they are the same more or less to RJ's but the average is very different.

Of course it's not impossible I loaded the wrong comparison? what was the file name?
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 15022
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: exxosuk
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Fri Aug 03, 2018 10:55 pm

Forgottenmyname wrote:
Fri Aug 03, 2018 10:49 pm
Could it be the different GB that I was using? If you look at the percentages for the 40mhz, they are the same more or less to RJ's but the average is very different.

Of course it's not impossible I loaded the wrong comparison? what was the file name?
STE20632... but maybe file isn't correct anymore :shrug:

Will have to see what Jonnie comes back with.. he has bother boosters working currently..
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?

User avatar
PhilC
Moderator
Moderator
Posts: 4144
Joined: Fri Mar 23, 2018 8:22 pm

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by PhilC » Fri Aug 03, 2018 10:57 pm

Fair enough, will wait with interest :D
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 15022
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: exxosuk
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Mon Aug 06, 2018 11:39 am

Jumping back to Franks' bob test program going funny viewtopic.php?f=24&t=46&start=190#p7843

I got a email back from Frank..

I’m not blit waiting plane to plane. I’m assuming the blitter will hog the bus and lock out the CPU while it is active. It's a bit nasty and it is relying on timing of the CPU/blitter.

So one of those "timing dependent" things (like raster etc) it seems. So all is well again :)

I am going to try and start building up some boards today...
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?

User avatar
exxos
Site Admin
Site Admin
Posts: 15022
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: exxosuk
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Mon Aug 06, 2018 4:37 pm

Made a start on a batch of 15...

People with OCD should not look at this image :twisted:

red15.jpg
red15.jpg (313.7 KiB) Viewed 2844 times
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 3949
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by rubber_jonnie » Mon Aug 06, 2018 4:44 pm

exxos wrote:
Mon Aug 06, 2018 4:37 pm

People with OCD should not look at this image :twisted:
You really should try harder to align all of the edges of the boards :dizzy:
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

Locked

Return to “STE V1 SERIES 32MHz BOOSTER”