TT VME Graphics - Revisited

Various tweaks and fixes from video ghosting to audio fixes etc.
Post Reply
Atarian Computing
Posts: 251
Joined: Tue Aug 22, 2017 4:27 am

TT VME Graphics - Revisited

Post by Atarian Computing » Fri Jul 27, 2018 10:57 am

Copied from my blog:TT VME Graphics - Revisited

Just recently I posted the article TT VME Bus Fix - Does it really make it faster? where I compared performance before and after Atari's VME Bus Fix which all REV.H motherboards and up seem to have. As kind of expected, the gains were not significant. I mean we would have noticed this years ago. What is unexpected, however, is the sudden performance boost (on average) than just a few days ago. So what has changed? Am I missing something? If so, let me know.

Before I show the results, here's what has changed (I'll list everything even if it is seemingly unrelated):
  • Motherboard recapped
    Rest of the rework done (My TT Gets Some Love)
    New storage (TT Cable Management and Cooling - Extreme Edition)
    New HDDriver version 10.12
    Lightning USB installed and drivers loaded
    New GAL and hardware mod to Nova as per Lightning installation.
    Fresh NVDI 5.03 installation with Nova option. (SYS files disabled as before).
    New English version of menu.prg
Not changed:
  • NVDI version
    Gembench version
    Nova drivers apart from menu.prg
    Test OS TOS 3.06 Thunder&Lightning edition
Here is a comparison in 1280x1024x256 against exact same reference. The difference is staggering but not all are gains if you look closely.
TT Before & After 1280x1024x256.jpg
TT Before & After 1280x1024x256.jpg (547.72 KiB) Viewed 325 times
And here is 1024x768x65536. Same story. Hard to believe that 16bit color at this resolution is almost as fast as TT-High.
TT Before & After 1024x768x65536.jpg
TT Before & After 1024x768x65536.jpg (506.17 KiB) Viewed 325 times
So how much faster is Mach64 to the ET4000? I happen to have both. The reference is before all fixes so keep that in mind. Also that test was done without NVDI so to be fair I tested without it now as well. Resolution is at 1024x768x256. Pretty crazy.
Mach64 vs ET4000.JPG
Mach64 vs ET4000.JPG (3.45 MiB) Viewed 325 times

User avatar
exxos
Site Admin
Site Admin
Posts: 4003
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: TT VME Graphics - Revisited

Post by exxos » Fri Jul 27, 2018 11:08 am

Looking at your first two screenshots, it looks like the blitter is running a few percent faster ? Which will up the scores on a lot of things...
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Atarian Computing
Posts: 251
Joined: Tue Aug 22, 2017 4:27 am

Re: TT VME Graphics - Revisited

Post by Atarian Computing » Fri Jul 27, 2018 11:23 am

exxos wrote:
Fri Jul 27, 2018 11:08 am
Looking at your first two screenshots, it looks like the blitter is running a few percent faster ? Which will up the scores on a lot of things...
It's actually the other way. I guess I should have named the files "After & Before". So despite the blitter actually being slower, my rig is significantly faster than before.

User avatar
exxos
Site Admin
Site Admin
Posts: 4003
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: TT VME Graphics - Revisited

Post by exxos » Fri Jul 27, 2018 11:32 am

Atarian Computing wrote:
Fri Jul 27, 2018 11:23 am
It's actually the other way. I guess I should have named the files "After & Before". So despite the blitter actually being slower, my rig is significantly faster than before.
Odd... maybe its the caches screwing things up ?
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Petari
Software Moderator
Software Moderator
Posts: 538
Joined: Tue Nov 28, 2017 1:32 pm

Re: TT VME Graphics - Revisited

Post by Petari » Fri Jul 27, 2018 11:33 am

Is there blitter in any TT ?
There is 2 kind of people: one thinking about moving to Mars after here becomes too bad, the others thinking about how to keep this planet habitable.

User avatar
exxos
Site Admin
Site Admin
Posts: 4003
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: TT VME Graphics - Revisited

Post by exxos » Fri Jul 27, 2018 11:54 am

Petari wrote:
Fri Jul 27, 2018 11:33 am
Is there blitter in any TT ?
ah, says NP in tests so no it seems :)
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Cyprian
Posts: 59
Joined: Fri Dec 22, 2017 9:16 am

Re: TT VME Graphics - Revisited

Post by Cyprian » Fri Jul 27, 2018 12:22 pm

there is no the BLiTTER in the TT
Jaugar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
Hatari / Steem SSE / Aranym / Saint
http://260ste.appspot.com/

Post Reply