Ultrasatan not detected.

Problems with your machine in general.
Post Reply
Encolpius
Posts: 3
Joined: Fri Nov 09, 2018 7:53 pm

Ultrasatan not detected.

Post by Encolpius » Fri Nov 09, 2018 8:04 pm

Hello everyone.

Bit of a saga here, so bear with me.

On Tuesday, my nice shiny new Ultrasatan arrived. I plugged it in to Esmerelda (my old STFM) and it worked absolutely spot on. I was in the middle of copying over my floppies to it when the mouse packed up. I thought something must have come loose, so I lifted the machine up and shoved the mouse back in. Unfortunately in so doing I wedged the Ultrasatan's ACSI plug against my monitor stand because I'm a malco and it fell out. I tried to reinsert it and rebooted the machine and was presented with a totally iconless desktop. Apparently this means my DMA is rekt.

Today, an allegedly 4 meg (actually only 1 meg, which means someone is getting negative feedback) STE arrived who we'll call Danica. The floppy drive works perfectly, but it won't even detect that I have an Ultrasatan plugged in. The Ultrasatan itself seems to work; it powers on, the green light flashes then each red light flashes, but the STE simply works the floppy drive looking for a disk. I opened up the STE and it has the so-called "good" DMA chip. However, it should detect that it is there at least.

The only thing I can think of is that the above incident wrecked the Ultrasatan. If so, how do I unwreck it?

User avatar
exxos
Site Admin
Site Admin
Posts: 4593
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Ultrasatan not detected.

Post by exxos » Fri Nov 09, 2018 8:24 pm

Have you re-tried it back on your STFM ?

STE's do suffer with hard drive problems.. but this sounds more like you may have broken the hard drive socket on your STE ?
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Encolpius
Posts: 3
Joined: Fri Nov 09, 2018 7:53 pm

Re: Ultrasatan not detected.

Post by Encolpius » Fri Nov 09, 2018 8:28 pm

The STFM is the one with the busted DMA and the one that the Ultrasatan was in when I wrecked the DMA. The STE didn't recognise it immediately I received it.

I could try to get a fresh cable and see if that works?

If it is the hard drive socket, how fixable is that given I am a malco?

User avatar
exxos
Site Admin
Site Admin
Posts: 4593
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Ultrasatan not detected.

Post by exxos » Fri Nov 09, 2018 8:34 pm

I would suggest you try to find someone to test your Ultra Satan for you to make sure it is not damaged.. If both your machines are likely damaged, then you're going to need it repaired. You need to rule out what is working and what is not working first of all..

I do sell sockets in my web store, but unless you are good with soldering, you should find someone else to do this work for you as you may cause more damage by trying to change the socket.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Encolpius
Posts: 3
Joined: Fri Nov 09, 2018 7:53 pm

Re: Ultrasatan not detected.

Post by Encolpius » Fri Nov 09, 2018 9:34 pm

This I can try, but I don't know anyone who has an ST in real life... Maybe next time there's a meet or something.

User avatar
exxos
Site Admin
Site Admin
Posts: 4593
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Ultrasatan not detected.

Post by exxos » Fri Nov 09, 2018 9:36 pm

Assuming you purchased UltraSatan from lotharek, I would suggest you ask him if you can return it for testing, as if it is broken, he is the only one who could fix it anyway..
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply