PaulJ's H4 Mongrel Build x 2

Topic for users to share their building progress.
Post Reply
User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 853
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: PaulJ's H4 Mongrel Build x 2

Post by PaulJ » Thu Dec 05, 2019 12:00 am

Just killed Bench6. Appears the machine is pretty solid. :)
Loop28.jpg
Loop28.jpg (318.9 KiB) Viewed 89 times

User avatar
exxos
Site Admin
Site Admin
Posts: 8614
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: PaulJ's H4 Mongrel Build x 2

Post by exxos » Thu Dec 05, 2019 12:03 am

:bravo:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 853
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: PaulJ's H4 Mongrel Build x 2

Post by PaulJ » Thu Dec 05, 2019 1:57 am

Found a issue.. serial failed cart loop back test.. tried with terminal and out works as seen on the diagrom output but it doesn't take input from the terminal. Midi works fine.

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 853
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: PaulJ's H4 Mongrel Build x 2

Post by PaulJ » Thu Dec 05, 2019 2:54 am

@Icky , @exxos I've got a board issue. It looks like rs232 in should go to pin 7 of the MAX238 but its now connected to pin 20 which is an output. I lifted pin 20 out of the socket and connect pin 7 and 20 together on the board and it now works.

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 853
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: PaulJ's H4 Mongrel Build x 2

Post by PaulJ » Thu Dec 05, 2019 3:12 am

derkom wrote:
Wed Dec 04, 2019 7:28 pm
Nice work @PaulJ! There go my dreams of competition glory. :lol:

Now that you have a working system, could you do me a favour and check the resistances between video DAC pins 7 and 8, 31 and 32, and 43 and 44 (i.e. three pairs)? I suspect something is up with mine there and would like to compare. Thanks!

EDIT: Oh yeah, and can you tell me how hot your DAC is getting? Mine's hot, right around pain threshold. Wondering if that's normal.
Derkom, do you have a pinout for the STV8438? The PDF I have shows it in a dip case only. Also I'm not sure resistance will tell you much, how about some scope images?

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 853
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: PaulJ's H4 Mongrel Build x 2

Post by PaulJ » Thu Dec 05, 2019 3:28 am

derkom wrote:
Wed Dec 04, 2019 7:28 pm
Nice work @PaulJ! There go my dreams of competition glory. :lol:

Now that you have a working system, could you do me a favour and check the resistances between video DAC pins 7 and 8, 31 and 32, and 43 and 44 (i.e. three pairs)? I suspect something is up with mine there and would like to compare. Thanks!

EDIT: Oh yeah, and can you tell me how hot your DAC is getting? Mine's hot, right around pain threshold. Wondering if that's normal.
Found it, looks like one direction is ~5.0 megohm and reversing the meter leads is ~5.4 megohm. Your better off looking at active signals than resistance readings. :D

derkom
Posts: 181
Joined: Sun Jul 29, 2018 6:45 pm

Re: PaulJ's H4 Mongrel Build x 2

Post by derkom » Thu Dec 05, 2019 7:28 am

PaulJ wrote:
Thu Dec 05, 2019 3:28 am
Found it, looks like one direction is ~5.0 megohm and reversing the meter leads is ~5.4 megohm. Your better off looking at active signals than resistance readings. :D
Okay, but there are three pairs of pins, one pair associated with each of R, G, and B, and what I'm actually interested to know is whether they're different. Were your readings ~5 MΩ for all three? This is what I see on my three pairs:

MUX_B0 -> BS : 3.76 M
MUX_G0 -> BS : 55 k
MUX_R0 -> BS : 1.2 M

I agree that looking at signals is a more instructive avenue, but this was just a quick test that made me go "hmmmm".

Here is the datasheet for the QFP version of the DAC: https://www.exdwh.com/data/STV8438CV.pdf

User avatar
exxos
Site Admin
Site Admin
Posts: 8614
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: PaulJ's H4 Mongrel Build x 2

Post by exxos » Thu Dec 05, 2019 8:50 am

PaulJ wrote:
Thu Dec 05, 2019 2:54 am
@Icky , @exxos I've got a board issue. It looks like rs232 in should go to pin 7 of the MAX238 but its now connected to pin 20 which is an output. I lifted pin 20 out of the socket and connect pin 7 and 20 together on the board and it now works.
Looks like I renamed the pin (where I would have had to delete the line to create a new one) and put it back on the wrong pin :(

1.JPG
1.JPG (144.45 KiB) Viewed 57 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 853
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: PaulJ's H4 Mongrel Build x 2

Post by PaulJ » Thu Dec 05, 2019 2:39 pm

derkom wrote:
Thu Dec 05, 2019 7:28 am
PaulJ wrote:
Thu Dec 05, 2019 3:28 am
Found it, looks like one direction is ~5.0 megohm and reversing the meter leads is ~5.4 megohm. Your better off looking at active signals than resistance readings. :D
Okay, but there are three pairs of pins, one pair associated with each of R, G, and B, and what I'm actually interested to know is whether they're different. Were your readings ~5 MΩ for all three? This is what I see on my three pairs:

MUX_B0 -> BS : 3.76 M
MUX_G0 -> BS : 55 k
MUX_R0 -> BS : 1.2 M

I agree that looking at signals is a more instructive avenue, but this was just a quick test that made me go "hmmmm".

Here is the datasheet for the QFP version of the DAC: https://www.exdwh.com/data/STV8438CV.pdf
Well my measurements were all approx. the same. The outlier was 43 & 44 where I got 5.6 and 6.1 megohm. So my measurements all ranged from 5.0 to 6.1 megohm. From my experience this is pretty mush a valueless measurement. It really depends on the ohm meter making a measurement through a semiconductor. The readings are significantly different though so you will have to draw your own conclusion. Like you said you may have fried the chips. Did you use hot air or soldering iron. I used a soldering iron which I'm comfortable with. I've tried hot air and have no faith in my ability to use it. Blowing the small components away or sitting there forever cooking things. I'll stick with a iron and leaded solder. TF did an excellent video on SMT soldering techniques. I don't have the link any longer but if you as him I'm sure he could point you in the right direct. :D

User avatar
PhilC
Moderator
Moderator
Posts: 2066
Joined: Fri Mar 23, 2018 8:22 pm

Re: PaulJ's H4 Mongrel Build x 2

Post by PhilC » Thu Dec 05, 2019 2:45 pm

PaulJ wrote:
Thu Dec 05, 2019 2:54 am
@Icky , @exxos I've got a board issue. It looks like rs232 in should go to pin 7 of the MAX238 but its now connected to pin 20 which is an output. I lifted pin 20 out of the socket and connect pin 7 and 20 together on the board and it now works.
I guess that explains why my serial dont work.
If it ain't broke, test it to Destruction.

Post Reply

Return to “MONGREL H4 USER BUILDS”