kodak80 H4 build (x2)

Topic for users to share their building progress.
User avatar
kodak80
Posts: 257
Joined: Sat Oct 21, 2017 1:14 am
Location: Brisbane,QLD Australia
Contact:

Re: kodak80 H4 build (x2)

Post by kodak80 » Mon Jan 20, 2020 11:31 am

I have double-checked my soldering on the fix PCB and everything looks fine but the fix PCB stops both floppy and SatanDisk working when installed in my H4.

Some testing with my multimeter.

With PAD1 disconnected from the GAL pin 7, I see 5v on IC6 pin 19 (HDCS), 0v on PAD1 on the fix PCB and 5v on pin 7 (FDCS) on the GAL socket.

With PAD1 connected to GAL pin 7, I see 0.3v on IC6 pin 19 and 5v on PAD1. There are no active disk icons in this state.
Atari Falcon 030 | Atari 1040 STE | Atari 1040 STFM | Atari 1040 STF | Kryoflux & Supercard Pro Flux boards
Creator of the Atari ST Review magazine archive: https://www.chillichai.com/atari-st-review

User avatar
exxos
Site Admin
Site Admin
Posts: 11851
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: kodak80 H4 build (x2)

Post by exxos » Mon Jan 20, 2020 11:35 am

Are you sure the pad on the pcb isn't shorted to gnd ?
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
kodak80
Posts: 257
Joined: Sat Oct 21, 2017 1:14 am
Location: Brisbane,QLD Australia
Contact:

Re: kodak80 H4 build (x2)

Post by kodak80 » Mon Jan 20, 2020 11:46 am

PAD1 is not shorted to GND. Have checked both in the H4 and out.
Atari Falcon 030 | Atari 1040 STE | Atari 1040 STFM | Atari 1040 STF | Kryoflux & Supercard Pro Flux boards
Creator of the Atari ST Review magazine archive: https://www.chillichai.com/atari-st-review

User avatar
kodak80
Posts: 257
Joined: Sat Oct 21, 2017 1:14 am
Location: Brisbane,QLD Australia
Contact:

Re: kodak80 H4 build (x2)

Post by kodak80 » Mon Jan 20, 2020 11:57 am

Can I confirm which way the inverter is expected to work. Looking at the SN74LVC1G04 pinouts, the feed from PAD1(FDCS) is the input and the inverted output is sent to IC6 pin 19.

So the 5v from GAL pin 7 to PAD1 shows 5v and thus IC6 pin 19 is 0v. It looks like the inverter is working correctly?
Atari Falcon 030 | Atari 1040 STE | Atari 1040 STFM | Atari 1040 STF | Kryoflux & Supercard Pro Flux boards
Creator of the Atari ST Review magazine archive: https://www.chillichai.com/atari-st-review

User avatar
derkom
Posts: 551
Joined: Sun Jul 29, 2018 6:45 pm

Re: kodak80 H4 build (x2)

Post by derkom » Mon Jan 20, 2020 12:01 pm

Are you sure your connection into the GAL socket is solid? I've found it difficult to get reliable connections into sockets with anything other than ICs or good pin headers. They'll generally pass the multimeter continuity test just fine, but won't pass data reliably at high frequencies.

FWIW, on my fix, which is basically a duplicate of Icky's, I soldered onto pin 19 on IC5, which is another source for FDCS. Works like a charm.

User avatar
kodak80
Posts: 257
Joined: Sat Oct 21, 2017 1:14 am
Location: Brisbane,QLD Australia
Contact:

Re: kodak80 H4 build (x2)

Post by kodak80 » Mon Jan 20, 2020 12:19 pm

I have soldered PAD1 to IC5 pin 19 and same results. No floppy and no SatanDisk. As I said the inverter chip is working as far as I can see and sending 0v to IC6 pin 19.
AAEAEC27-0CC4-400C-A605-D04C60CE78D6.jpeg
AAEAEC27-0CC4-400C-A605-D04C60CE78D6.jpeg (115.67 KiB) Viewed 823 times
I will try this on my other H4 tomorrow and see if I get the same result or not. Time for bed now.
Atari Falcon 030 | Atari 1040 STE | Atari 1040 STFM | Atari 1040 STF | Kryoflux & Supercard Pro Flux boards
Creator of the Atari ST Review magazine archive: https://www.chillichai.com/atari-st-review

User avatar
kodak80
Posts: 257
Joined: Sat Oct 21, 2017 1:14 am
Location: Brisbane,QLD Australia
Contact:

Re: kodak80 H4 build (x3)

Post by kodak80 » Fri Feb 14, 2020 8:49 pm

Just confirming that Gazak’s H4 is now up and running so this is now 3 live in Queensland. Not sure when Paul will commence building the other 2.

We will be testing Gazak’s H4 today with his UltraSatan hard disk.
Atari Falcon 030 | Atari 1040 STE | Atari 1040 STFM | Atari 1040 STF | Kryoflux & Supercard Pro Flux boards
Creator of the Atari ST Review magazine archive: https://www.chillichai.com/atari-st-review

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 1349
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: kodak80 H4 build (x2)

Post by PaulJ » Fri Feb 14, 2020 9:13 pm

Nice job for the guys down under. :thumbup: :thumbup: :thumbup:

User avatar
kodak80
Posts: 257
Joined: Sat Oct 21, 2017 1:14 am
Location: Brisbane,QLD Australia
Contact:

Re: kodak80 H4 build (x3)

Post by kodak80 » Sat Feb 15, 2020 12:30 pm

AAEAEC27-0CC4-400C-A605-D04C60CE78D6.jpeg
AAEAEC27-0CC4-400C-A605-D04C60CE78D6.jpeg (71.73 KiB) Viewed 716 times
Okay, worked on this today. Helps if you put the LS245 in the right position on the fix PCB! Once the IC was in the right place, this DMA buffer fix PCB worked fine.

Also, tested the UltraSatan and this worked fine with the floppy disk. Didn't need to replace the resistors as indicated by Exxos.

We also turned on the floppy 1.44mb GAL chip and this worked fine as well. Could access 1.44mb and 720k floppy disks.

5C27F148-17E8-4651-804A-D92D059BC219.jpeg
5C27F148-17E8-4651-804A-D92D059BC219.jpeg (107.66 KiB) Viewed 712 times
F97721DD-C735-4384-B082-C6DC4FAA4061.jpeg
F97721DD-C735-4384-B082-C6DC4FAA4061.jpeg (106.19 KiB) Viewed 712 times
So today was very successful for testing the H4. All testing was done on board #3. So now need to do the DMA fix and floppy 1.44mb updates on board #1 and #2.
Atari Falcon 030 | Atari 1040 STE | Atari 1040 STFM | Atari 1040 STF | Kryoflux & Supercard Pro Flux boards
Creator of the Atari ST Review magazine archive: https://www.chillichai.com/atari-st-review

User avatar
exxos
Site Admin
Site Admin
Posts: 11851
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: kodak80 H4 build (x2)

Post by exxos » Sat Feb 15, 2020 1:30 pm

Great stuff well done! :cheers:
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply

Return to “MONGREL H4 USER BUILDS”