Broken vacuum speed controller a closer look :p

Atari talk, or the life and the universe and things. Just keep it clean!
Post Reply
User avatar
DrF
Moderator
Moderator
Posts: 520
Joined: Thu Aug 17, 2017 1:18 pm

Broken vacuum speed controller a closer look :p

Post by DrF » Sat Oct 12, 2019 1:45 pm

Vacuum had some weird faults, it started switching between speeds constantly, until it eventually got stuck on the low setting.
I removed the speed controller because I refuse to buy one and bypassed it so its stuck in the high speed setting which is what it spent its life on anyhow. Here's the board that was removed, im wondering if this thing heated up so far that the small I think it's a smd capacitor moved and caused the problems see if you can spot the issue. I can't see a pad under it cause well its covered in crap so I can't tell if it was meant to be soldered that way or it moved?
20191012_131351.jpg
20191012_131351.jpg (112.54 KiB) Viewed 81 times
20191012_131318.jpg
20191012_131318.jpg (68.13 KiB) Viewed 81 times
20191012_131249.jpg
20191012_131249.jpg (68.26 KiB) Viewed 81 times
20191012_131153.jpg
20191012_131153.jpg (69.42 KiB) Viewed 81 times

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 1360
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Broken vacuum speed controller a closer look :p

Post by rubber_jonnie » Sat Oct 12, 2019 1:59 pm

Hmm, that cap looks like a bodge to me, I can't honestly imagine how it has been hot enought to melt solder without causing other problems and showing signs of heat damage.
Collector of old Atari things:
800XL + Ape Warp mod, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg) + Gotek, 1040STFM + Vortex ATOnce + Gotek, 1040STF long button floppy, 4160 STE with Gotek and ROM switcher, 4160STE with 32Mhz booster, ROM switcher and CosmosEx, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
PhilC
Moderator
Moderator
Posts: 1802
Joined: Fri Mar 23, 2018 8:22 pm

Re: Broken vacuum speed controller a closer look :p

Post by PhilC » Sat Oct 12, 2019 2:46 pm

Yeah that cap looks deliberate as it is
If it ain't broke, test it to Destruction.

User avatar
DrF
Moderator
Moderator
Posts: 520
Joined: Thu Aug 17, 2017 1:18 pm

Re: Broken vacuum speed controller a closer look :p

Post by DrF » Sat Oct 12, 2019 4:39 pm

Funny you mention heat as that was one of the complaints about the thing it was getting hot, that board hooks straight into the 240v supply, its pretty black but don't look like the pcb is trashed.

All i assume it does is turn the voltage down slowing the motor down not like its a super complex device.

User avatar
exxos
Site Admin
Site Admin
Posts: 7832
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Broken vacuum speed controller a closer look :p

Post by exxos » Mon Oct 14, 2019 12:15 am

Its normally the big transistor which fails., they overheat and die. Then you get stuck on full power or normally low power...or sometimes just fire :lol:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply

Return to “CHAT FORUM”