Gotek / HxC Manager problem

Update your old 720k to a 1.44 drive etc.
bfollowell
Posts: 52
Joined: Wed Oct 24, 2018 6:53 am

Gotek / HxC Manager problem

Post by bfollowell » Mon Feb 10, 2020 4:05 pm

My HxC Manager has stopped working.

I moved my Gotek to another computer/drive to check out that system and when I select slot 000 for the HxC Manager, it won't load. I get a blank white screen for a second or two, then the Loading HxC Manager message with all the periods, then the screen blanks white again, then nothing, no matter how long I wait. If I select another slot, one of the few that I'd setup when HxC manager was working, the images load and everything is fine. I just can no longer load HxC Manager to add/remove/modify image slots.

I tried copying over a fresh copy of AUTOBOOT.HFE and HXCSDFE.CFG, but it didn't help. I formatted my flash drive then reinstalled everything, but that didn't help either.

Any ideas?

Thanks.

User avatar
PhilC
Moderator
Moderator
Posts: 2363
Joined: Fri Mar 23, 2018 8:22 pm

Re: Gotek / HxC Manager problem

Post by PhilC » Mon Feb 10, 2020 4:21 pm

I've split this from the flash floppy thread as its a little off topic and hopefully you'll get a more informed reply with it being a new topic.
If it ain't broke, test it to Destruction.

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 1698
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Gotek / HxC Manager problem

Post by rubber_jonnie » Mon Feb 10, 2020 4:47 pm

Have you tried a different USB stick? I found that they can vary, working one day but not the next.

Be sure you are using FAT32 and that the USB stick is 32GB max, with Autoboot.HFE in the root.

Also, what firmware are you using on the Gotek? Is it FlashFloppy? If so make sure you're using the latest version, and alternatively you can try rolling back the version to an earlier one.

If it's HxC you may want to try going to the latest version too.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

bfollowell
Posts: 52
Joined: Wed Oct 24, 2018 6:53 am

Re: Gotek / HxC Manager problem

Post by bfollowell » Mon Feb 10, 2020 6:02 pm

Starting a new thread was probably a better idea. Thanks PhilC.

I guess anything is possible, but I seriously doubt that it's the flash drive. I use SanDisk almost religiously and have never had any issues with anything application I've used them on. Also, this particular drive has worked in this application for months, until just the past day or so. It's a 32GB SanDisk Cruzer Fit, formatted to FAT32, with the proper files on it. I have other drives I could try of different models, but almost every single one is a SanDisk. I'll try another later.

And yes, I plan to register the HxC firmware later and use that, but the two Goteks I'm working with now are on STs that I plan to sell, and they're using FlashFloppy. The newest one that I setup is v2.14. I'm not certain on the older one, the one that started experiencing this issue. I only set it up a couple of months ago, and I used the latest revision out at that time, so it could be the same version, but I'm not certain.

tzok
Posts: 163
Joined: Sat Dec 30, 2017 2:27 pm

Re: Gotek / HxC Manager problem

Post by tzok » Mon Feb 10, 2020 10:34 pm

If you are using a Flash Floppy, then download an image manager supplied with the firmware version together with a right config files. You need to put these files on the root of your flash drive:
ff.cfg
img.cfg
HXCSDFE.CFG
AUTOBOOT.HFE

You will find all these files in the archive with Flash Floppy firmware.

bfollowell
Posts: 52
Joined: Wed Oct 24, 2018 6:53 am

Re: Gotek / HxC Manager problem

Post by bfollowell » Mon Feb 10, 2020 10:48 pm

As I stated, I moved this FlashFloppy Gotek from one machine to another. It was working fine before. There's no way I could've ever had it working without the basic boot & config files.

I have: HXCSDFE.CFG & AUTOBOOT.HFE

I have never used ff.cfg & img.cfg. Those aren't required, at least not when using the free HxC Manager.

bfollowell
Posts: 52
Joined: Wed Oct 24, 2018 6:53 am

Re: Gotek / HxC Manager problem

Post by bfollowell » Mon Feb 10, 2020 10:57 pm

Well, after some more tinkering, I found that one of my Goteks has FF 2.13 and the other has FF 2.14. They both still work just fine with my 520STM when housed in an SF314 case. It's only when I put them in my 1040STF that neither will work, though they have in the past. There definitely seems to be something about that machine that I need to investigate further.

JezC
Posts: 204
Joined: Mon Aug 28, 2017 11:44 pm

Re: Gotek / HxC Manager problem

Post by JezC » Tue Feb 11, 2020 8:11 am

I've had two different Gotek drives working in my 10540 STF (at different times) - one with HxC firmware & the other with FlashFloppy (but probably quite an old version).

So, it can work in the STF - I also had the same drives working in an external floppy case also (with no changes to the Gotek between being mounted internally & externally) so I'd expect it's something simple.

If you are still fighting it, I will try & check it (and what FF version I'm using) this evening & let you know.

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 1698
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Gotek / HxC Manager problem

Post by rubber_jonnie » Tue Feb 11, 2020 11:19 am

bfollowell wrote:
Mon Feb 10, 2020 6:02 pm
Starting a new thread was probably a better idea. Thanks PhilC.

I guess anything is possible, but I seriously doubt that it's the flash drive. I use SanDisk almost religiously and have never had any issues with anything application I've used them on. Also, this particular drive has worked in this application for months, until just the past day or so. It's a 32GB SanDisk Cruzer Fit, formatted to FAT32, with the proper files on it. I have other drives I could try of different models, but almost every single one is a SanDisk. I'll try another later.

And yes, I plan to register the HxC firmware later and use that, but the two Goteks I'm working with now are on STs that I plan to sell, and they're using FlashFloppy. The newest one that I setup is v2.14. I'm not certain on the older one, the one that started experiencing this issue. I only set it up a couple of months ago, and I used the latest revision out at that time, so it could be the same version, but I'm not certain.
I use FF exclusively, though off the top of my head I couldn't say which version I'm on. BUT I have had USB sticks that work perfectly well suddenly misbehave and need a reformat. Sometimes they never work again with the Gotek and I need to swap out, so it's always worth checking.

No reason it shouldn't work in an STF, it presents as a floppy drive, so the STF shouldn't care. I presume the only jumper you have set is S0? You shouldn't need any other jumpers set, so that's worth a check.

Also, might be worth checking that you're getting good power to the Gotek too.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

bfollowell
Posts: 52
Joined: Wed Oct 24, 2018 6:53 am

Re: Gotek / HxC Manager problem

Post by bfollowell » Tue Feb 11, 2020 1:25 pm

I haven't checked much into the STF yet, but plan to soon, as that will be my next machine to sell and I plan to put a Gotek in it. So far, both of my existing Goteks, using FlashFloppy 2.13 and 2.14, work perfectly with my 520STM inside an SF314 case, and with my 1040STE. Also, at least one of them has worked with my STF in the recent past. I while checking out my actual, physical disk drives, there was a whole lot of plugging and unplugging going on, so I could've broken a cable or something. That happened to a power lead inside the SF314 case when I was checking it out, and I had to repair that, so I could easily see it being something similar inside the STF. I'll check it out later, when I get a chance.

It's just really weird, because it seems to start, the quits before making it very far. HxC Manager tried to start, but freezes before loading the menu. Dungeon Master tries to start, the screen turns black, then freezes right before the big FTL swoosh appears. Zork III goes to desktop, I can see the files on the disk, it acts like it's trying to start when I double-click on the icon, but the game never actually starts. The only thing that seems to work is the SysInfo 8.34 image I have. It goes to desktop and it will successfully start and I can look through the various screens.

I do have one physical floppy drive that still works decently. Maybe I'll copy Zork III or something simple from an image onto a real disk and see if I have the same issue with a real disk. At least then it would help me narrow the problem down from the Gotek to the computer.

Post Reply

Return to “FLOPPY DRIVES KITS & UPGRADES”