STE V1.5 32MHz BOOSTER - STATUS

Help & information about the STE V1 booster.
User avatar
rpineau
Site Admin
Site Admin
Posts: 409
Joined: Thu Aug 17, 2017 6:08 pm
Location: USA
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by rpineau » Fri Jun 08, 2018 7:30 pm

very weird indeed
Working ones : MegaSTE (68020) / TT030 / Falcon with AB040 & Eclipse / 1040STF
Need testing : Falcon with CT2

Forgottenmyname
Trusted Guru
Trusted Guru
Posts: 692
Joined: Fri Mar 23, 2018 8:22 pm

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by Forgottenmyname » Fri Jun 08, 2018 7:42 pm

Just a random suggestion.

Is it possible that the board is warping underneath the cpu after it's been on load and warmed up? thus breaking some of the contacts onto the socket on the MB.?

User avatar
exxos
Site Admin
Site Admin
Posts: 5032
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Fri Jun 08, 2018 7:55 pm

Forgottenmyname wrote:
Fri Jun 08, 2018 7:42 pm
Is it possible that the board is warping underneath the cpu after it's been on load and warmed up? thus breaking some of the contacts onto the socket on the MB.?
Its possible a solder connection has broke... I mean the CPU ran direct in the MB... but I did check bus activity before I took it out, and CPU did put /AS low several times and DTACK issued also..

I've been heating up my second board a lot.. but nothings died and its almost smoking now :lol: Even so, the CPU hardly gets warm anyway. The GAL actually gets a lot hotter than the CPU.

I did try pushing down on the CPU pretty hard before I removed the CPU from the board...Though if it was a bad connection on the board, its take like 30+ hours to show up.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Forgottenmyname
Trusted Guru
Trusted Guru
Posts: 692
Joined: Fri Mar 23, 2018 8:22 pm

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by Forgottenmyname » Fri Jun 08, 2018 8:03 pm

30 hours and a pig to find, especially how that CPU is mounted to the board i bet.

I work in hot boiler houses and component failure due to heat is a big thing for me.

You'll sort it I'm sure....

(Unlike me and the Mega, having a break, lol)

User avatar
exxos
Site Admin
Site Admin
Posts: 5032
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Sat Jun 09, 2018 9:53 am

I left it running overnight, and will leave it running today also as much as possible. Currently its at loop 261... The previous board got to around loop 120.. Though it had been running several hours for the past week before that...

So I am leaning towards its more PCB related than CPU...
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 5032
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Sun Jun 10, 2018 1:15 am

Must have been running 30+ hours constantly now and got to loop 461. So must have been a bad solder joint or bad PCB on the previous board.. So looks like all is well in the world again :D
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 5032
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Mon Jun 11, 2018 2:34 pm

So a bit more chaos today..

I had on the board 2x220R (normal wire ended types ) resistors on the buffer input and this is what was working fine. So I change this for a normal 100R 1206, and it crashed after about 30 seconds :roll: obviously the system should not be that critical over just a few ohms.. So I had a little bit more investigation to do..

Cut a long story short, I think just a tiny bit of noise on the 40MHz line is enough to cause problems.. The input value resistor to the buffer seemed overcritical in all my previous tests and of course this was proven again today. I tried a lot of things, there was seems to work is simply placing a 22pF capacitor on the buffer input. Now I am going via a 33R resistor and it all seems fine again.

I'm using a schmitt buffer, so it should filter out all sorts of noise and glitches. Obviously there is something else going on which it is not filtering out. It's not relating to minimum or maximum voltages as I did a lot of experimenting with that this morning. Even altering DC offset levels etc..

In any case, I will update the PCB design to include this capacitor.. I will leave the board on testing throughout today again to make sure's works.. I'm not too worried about investigating this issue.. If I investigate every tiny little thing the project will never move forward..

In relation to the dualtos boards, where currently I am soldering on the ROM directly onto the PCB.. The problem is that I wanted to keep stock of the ROM's separately in order to keep costs down a lot. It is not really practical to build up 20 of each language.. It's why I put a lot of the current boards (with sockets) built up, so I can keep a large stock of them, I just program low quantity of ROMs as needed. But obviously this would be a huge problem if I went to solder all the ROM's onto the new PCBs...

So I'm going to order a few SMT sockets and see if these are better than the larger through-hole sockets.. I don't have any spare boards, so I will have to order some more, so it could be some time before updating relation to those...
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 5032
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Fri Jun 15, 2018 2:47 pm

The sockets I investigated in another thread... viewtopic.php?f=23&t=74&p=6567#p6567

And I just on the changes to the DualTOS board.. I also added on the list as previously mentioned...

Will get some prototypes made soon..

22.jpg
22.jpg (24.55 KiB) Viewed 649 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 5032
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Fri Jun 22, 2018 5:09 pm

I've ordered 3 of the final revision boards. Which are the new dualtos boards & plug in booster boards and stencils.

If all goes well, they will be 2 sets of boards which will be up for sale once tested out. I don't know what price these will be yet, but likely more expensive than the current boards in my store due to assembly and prototype costs.. But they will likely be still cheaper than the final store price... In any case if anyone wants to call dibs on one then let me know and I will try and remember :)

b1.jpg
b1.jpg (42.05 KiB) Viewed 533 times
b2.jpg
b2.jpg (22.11 KiB) Viewed 533 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Forgottenmyname
Trusted Guru
Trusted Guru
Posts: 692
Joined: Fri Mar 23, 2018 8:22 pm

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by Forgottenmyname » Fri Jun 22, 2018 5:15 pm

Oh go on then, you twisted my arm....

And hopefully that'd help with the drop in sales too..... but will want some1mb simms too if I'm selected to be the guinea pig, lol.

Post Reply