STE V1.5 32MHz BOOSTER - STATUS

Help & information about the STE V1 booster.
Locked
User avatar
exxos
Site Admin
Site Admin
Posts: 7589
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Mon Aug 06, 2018 11:39 am

Jumping back to Franks' bob test program going funny viewtopic.php?f=24&t=46&start=190#p7843

I got a email back from Frank..

I’m not blit waiting plane to plane. I’m assuming the blitter will hog the bus and lock out the CPU while it is active. It's a bit nasty and it is relying on timing of the CPU/blitter.

So one of those "timing dependent" things (like raster etc) it seems. So all is well again :)

I am going to try and start building up some boards today...
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7589
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Mon Aug 06, 2018 4:37 pm

Made a start on a batch of 15...

People with OCD should not look at this image :twisted:

red15.jpg
red15.jpg (313.7 KiB) Viewed 1498 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 1330
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by rubber_jonnie » Mon Aug 06, 2018 4:44 pm

exxos wrote:
Mon Aug 06, 2018 4:37 pm

People with OCD should not look at this image :twisted:
You really should try harder to align all of the edges of the boards :dizzy:
Collector of old Atari things:
800XL + Ape Warp mod, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg) + Gotek, 1040STFM + Vortex ATOnce + Gotek, 1040STF long button floppy, 4160 STE with Gotek and ROM switcher, 4160STE with 32Mhz booster, ROM switcher and CosmosEx, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
PhilC
Moderator
Moderator
Posts: 1703
Joined: Fri Mar 23, 2018 8:22 pm

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by PhilC » Mon Aug 06, 2018 5:46 pm

It's the one that's incorrectly rotated that annoys me :mrgreen:
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 7589
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Mon Aug 06, 2018 5:47 pm

Forgottenmyname wrote:
Mon Aug 06, 2018 5:46 pm
It's the one that's incorrectly rotated that annoys me :mrgreen:
:thumbup:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

stephen_usher
Posts: 315
Joined: Mon Nov 13, 2017 7:19 pm
Location: Oxford, UK.
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by stephen_usher » Mon Aug 06, 2018 5:50 pm

Forgottenmyname wrote:
Mon Aug 06, 2018 5:46 pm
It's the one that's incorrectly rotated that annoys me :mrgreen:
Surely it's all but one is the wrong way around? ;-)
Intro retro computers since before they were retro...
ZX81->Spectrum->Memotech MTX->Sinclair QL->520STM->BBC Micro->TT030->PCs & Sun Workstations.
Added code to the MiNT kernel (still there the last time I checked) + put together MiNTOS.
Collection now with added Macs, Amigas, Suns and Acorns.

User avatar
PhilC
Moderator
Moderator
Posts: 1703
Joined: Fri Mar 23, 2018 8:22 pm

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by PhilC » Mon Aug 06, 2018 5:52 pm

stephen_usher wrote:
Mon Aug 06, 2018 5:50 pm
Forgottenmyname wrote:
Mon Aug 06, 2018 5:46 pm
It's the one that's incorrectly rotated that annoys me :mrgreen:
Surely it's all but one is the wrong way around? ;-)
:lol: so that's why I found it annoying.
If it ain't broke, test it to Destruction.

User avatar
IngoQ
Site Admin
Site Admin
Posts: 811
Joined: Tue Aug 22, 2017 8:38 am
Location: Germany

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by IngoQ » Tue Aug 07, 2018 7:06 am

I don't like the gap between 1st and 2nd of the middle row :-P
Ingo :geek:

| Atari 1040STE@32MHz | Amiga 1200 (ACA1220) | Atari 800XL (U1MB, SIDE2) | Atari 130XL (Sophia DVI) | C64 (1541 Ultimate II, Rev3 RFMod Replacement) | TI 99/4A (F18A, 32k, FlashROM 99) | Sinclair ZX Spectrum 128 (Stereo, DivMMC) | Amstrad CPC664 (512k, M4 Wifi) | ... |

User avatar
exxos
Site Admin
Site Admin
Posts: 7589
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by exxos » Thu Aug 09, 2018 11:06 am

One thing I noticed the other day which I need to look at the bit more.. Was that HD10.01 driver crashed on boot up in 40MHz mode. I am not sure if anything else was loading in the AUTO folder.. I need to check will not had chance yet..

Basically when HD10 loaded it would bomb out. You'll thing is if I booted in 8MHz mode it would all load fine, and then the driver seemed to work fine in switching back to 40MHz mode. I emailed Uwe about it, he says it works on other machines like the Milan etc and that there is no timing dependent code in HD10..

So if any of you guys with this booster can try it out, really just load the driver from the floppy, and see if it bombs on boot or not.. I will try and do this myself bought I'm going to be busy today some other stuff..

EDIT:
The driver might actually loaded from my ultra Satan... Can't remember now :roll:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PhilC
Moderator
Moderator
Posts: 1703
Joined: Fri Mar 23, 2018 8:22 pm

Re: STE V1.5 32MHz BOOSTER - STATUS

Post by PhilC » Thu Aug 09, 2018 8:22 pm

Will try and give it a go this weekend from Floppy.

I don't suppose you have a link to the file do you? Still an STe newb here.

I have an ultrasatan but only the correct cables for a Mega ST.
If it ain't broke, test it to Destruction.

Locked